Dashboard failures: Billing Page and Account Creation down
Incident Report for ngrok
Resolved
This incident has been resolved.
Posted Nov 27, 2024 - 02:13 UTC
Monitoring
A fix has been deployed which resolves the issue and restores all dashboard functionality. We are monitoring to ensure that the fix is correct.
Posted Nov 27, 2024 - 01:54 UTC
Identified
We are tracking an issue that prevents new accounts from being created, existing accounts from being deleted and also results in failures to access the billing subscription page to view or manage an account's subscription. We are preparing a fix for deployment.

No other services are known to be affected at this time.
Posted Nov 27, 2024 - 01:35 UTC
This incident affected: Dashboard (https://dashboard.ngrok.com).