Delay in generating and renewing certificates for custom domains

Incident Report for ngrok

Resolved

This has been resolved
Posted May 08, 2026 - 22:21 UTC

Monitoring

Our provider has fixed their system.
Posted May 08, 2026 - 21:28 UTC

Investigating

Our certificate provider has run into an issue and is currently pausing generation and renewal of certificates.
Posted May 08, 2026 - 20:12 UTC
This incident affected: Certificates.