Traffic Inspector events in EU region not populating for some customers

Incident Report for ngrok

Resolved

This issue has been resolved
Posted Jun 01, 2025 - 04:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 30, 2025 - 15:18 UTC

Investigating

We are currently investigating this issue.
Posted May 29, 2025 - 17:35 UTC
This incident affected: Events.