Some Tunnel Restarts Break Endpoints

Incident Report for ngrok

Resolved

The fix is now rolled out to all regions, and our team has confirmed we are seeing no more instances of the issue.
Posted Aug 15, 2023 - 23:43 UTC

Update

After further monitoring, we have a set of fixes we believe to be comprehensive. We are rolling these out to all regions now.
Posted Aug 15, 2023 - 22:41 UTC

Update

We are still seeing intermittent failures around rare edge cases. The team is continuing to work on a fix.
Posted Aug 15, 2023 - 21:07 UTC

Monitoring

A fix has been rolled out, and we are monitoring for additional impact or recurrence.
Posted Aug 15, 2023 - 20:35 UTC

Identified

The issue has been identified, and a fix is being implemented.
Posted Aug 15, 2023 - 19:21 UTC

Investigating

In some cases, when a user restarts a tunnel the new endpoint does not function.
Posted Aug 15, 2023 - 17:57 UTC
This incident affected: Agent Connectivity (Region - AP, Region - AU, Region - EU, Region - IN, Region - JP, Region - SA, Region - US).