ngrok fallback certs being served for regional domains outside the region
Incident Report for ngrok
Resolved
We believe this issue to be resolved for all customers.
Posted Jun 29, 2023 - 22:50 UTC
Monitoring
Remediation is deployed in all regions. We believe the issue is resolved for all customers and are monitoring for recurrences.
Posted Jun 29, 2023 - 22:46 UTC
Update
We are working on a remediation and will update within the next hour.
Posted Jun 29, 2023 - 22:09 UTC
Identified
We have discovered and reproduced an error in which customers with regional, reserved, wildcard domains will see an ngrok owned certificate when accessing their endpoint from a region their tunnel was not started in. This is not the default path or possible via the dashboard.
Posted Jun 29, 2023 - 21:16 UTC
This incident affected: Endpoint Connectivity (Region - AP, Region - AU, Region - EU, Region - IN, Region - JP, Region - SA, Region - US).