Delays issuing certificates

Incident Report for ngrok

Resolved

This incident has been resolved.
Posted Jun 19, 2026 - 05:04 UTC

Monitoring

System is stable and generating certificates - monitoring for changes upstream.
Posted Jun 19, 2026 - 00:10 UTC

Identified

Our certificate provider is experiencing an outage and you may experience a delay in seeing your certificate issued for domain in the system.
Posted Jun 18, 2026 - 20:16 UTC
This incident affected: Certificates.